Release Notes

  RailClone Lite/Pro 3.2.0

New Features and Improvements

  • Added support for V-Ray Next

  • Added Support for 3ds Max 2019

  • Added Support for Arnold 5.1 and above

    • Includes RailClone Colour support

  • Updated library with Arnold materials

  • Added Supermarket products to the free library. Include 10 new presets, each with multiple product variations.

  • Bevels now can be used with Count mode

  • Bevels now can be used with Adaptive mode.

    • "Bevel Mode" and "Bevel Offset" have no effect. In all cases is used the same type of bevel with offset 0.

  • Added "Sync between Generators" to "Random" node. It lets to generate same random values for all Generators.

  • Added UVW XForm->"Rotate about Center".

    • It has no effect with Segment's mapping.

    • To make it work identically to the UVW XForm Max modifier, now Scale is applied after Rotation (previously Scale was applied before Rotation).

  • Added improvements to Update Manager.

    • Update manager can be configured to check if a library has already been downloaded to a network locations. This can save multi-user offices from having to download the same content multiple times.

  • iToo Toolbars (both Forest and RailClone) can be disabled adding the following registry key:
    HKEY_CURRENT_USER\Software\Itoo Software\DisableToolbars = 1 (DWORD)

  • Modifiers in RailClone objects are used on nested objects.

    • Only if Segment->Nest is not enabled in the outer object. This mode is not compatible with modifiers.

  • Added "SubSplineCounter" to expressions.

    • Index of sub-spline when using compound X splines. Valid both for array and linear generators. Starts in 0.

  • Several array inputs have been renamed, to more understable names according its operation.

    • Left Side -> Start, Right Side -> End, Top Side -> Top, Bottom Side -> Bottom, Inner Corner -> X Corner, LT Corner -> Start Top, RT Corner -> End Top, LB Corner -> Start Bottom, RB Corner -> End Bottom

  • For "Style->Free Object" the full spline's transformation is ignored (Position/Rotate/Scale), not only Position as before.

    • This fixes a problem with XRef scenes binded to a rotated object.

    • Existing scenes may be affected if were using the Rotation or Scale of the spline. This can be fixed re-aligning the RC object with the spline (ie. using Alt+A) for rotation, and applying a Reset XForm to the spline, for scale.

  • Added warning when using Point-cloud mode with nested RC objects.

Fixes

  • Fixed: Bevel Extend and Symmetric options are swapped.

  • Fixed: When Evenly->Mode parameter is exported, modifies value of Clipping->Mode.

    • To fix it on existing styles it's necessary to recreate the Generator.

  • Fixed: Evenly mode generates extra segments on closed splines.

  • Fixed: unable to export parameters with same name.

  • Fixed: Update Manager doesn't close properly when launched on silently mode.

  • Fixed: Display->"Use Instance Engine" has no effect in Arnold (always is on).

  • Fixed rare crash in Expression Editor with some operations (i.e. using Undo when focus is on viewport).

  • Fixed issue when Evenly distance is lower than the Evenly Segment size.

  • Fixed: Sequence and Material->Sequence operators start with 2 same segments.

  • Fixed: animated Clipping splines are not updated correctly.

  • Fixed: Style Editor is not closed automatically when RC object is deselected, if an expression is being edited.

  • Fixed bugs with No-Bend segments and Y Splines in Arrays.

  • Fixed issues with auto alignment to X->XY.

  • Fixed crash using Numeric nodes copied from a macro in the main style.

    • Numeric nodes of main and macro styles are not interchangeable. Now RC blocks this possibility in copy-paste operations.

  • Fixed: Input macro nodes of different types can be rewired.

  • Fixed: Macro outputs cannot be rewired with a node of same type.

  • Main configuration of the plugin can be defined using environment variables:

    • Each registry key used in the configuration may be replaced by a variable, replacing non alphanumeric characters by '_'.

      For example: for "HKEY_LOCAL_MACHINE\SOFTWARE\Itoo Software\RailClone Pro\MainDir", you must define the variable "ITOO_SOFTWARE_RAILCLONE_PRO_MAINDIR"

    • The minimum variables to run RailClone Pro are the following:

      For Network licenses:    ITOO_SOFTWARE_RAILCLONE_PRO_MAINDIR=C:\Program Files (x86)\Itoo Software\RailClone Pro
      ITOO_SOFTWARE_LICENSES_LICENSEDIR=C:\ProgramData\Itoo Software\Licenses
      ITOO_SOFTWARE_RAILCLONE_PRO_USELICSERVER=1
      ITOO_SOFTWARE_RAILCLONE_PRO_LICSERVHOST=192.168.1.20
      ITOO_SOFTWARE_RAILCLONE_PRO_LICSERVPORT=16720

      For Stand-alone licenses:
      ITOO_SOFTWARE_RAILCLONE_PRO_MAINDIR=C:\Program Files (x86)\Itoo Software\RailClone Pro
      ITOO_SOFTWARE_LICENSES_LICENSEDIR=C:\ProgramData\Itoo Software\Licenses
      ITOO_SOFTWARE_RAILCLONE_PRO_USELICSERVER=0

    • If you define the variables in a .BAT file, be sure to not include any space at both sides of the '=' symbol, or it will not work (this is a known Windows issue).

    • Environment variables are used only by the Max plugin. Other tools as the License Manager requires configuration registry keys stll.

    • If both registry keys and environment variables are defined, the variables have precedence over keys (priority order is Variables->HKLM->HKCU).

  • Fixed problems with Adaptive mode.

  • Fixed precision error when segment ends just at the spline's limit.

  • Fixed crash in Style Editor dragging a Macro category (not a macro) from the Macros tree.

  • Fixed Style->Geometry->Vertex Weld, which was broken in latest release.

  • Fixed: in Point-cloud mode, Z-Offset is applied twice for segments with Bend off.

  • Fixed bug computing Corner on first vertex of closed splines.

  • Fixed resizing Note nodes when Style Editor is zoomed.

  • Fixed "Simple Y Offset mode" with collinear vertices.

  • Fixed bug when using "Extend X/Z Size to Area" and "X-->XY" mode with splines coplanar to XY.

  RailClone Lite/Pro 3.1.0
  • Added support for V-Ray Next beta 1 (experimental).

  • Added "Force Instances" to RailClone Tools.
    * When enabled, the Instantiate tool generates as many instances as possible, ignoring Material and UVW operators.
    * This option mimics the behaviour of RC Tools previous to v3.0.9.

  • Arrays generated from clipping areas use Mat.ID of spline for Selector, Conditional and Expressions nodes.
    * Note: ID is taken from the first spline's segment.

  • Improved text visibility of "Note" nodes, according to the background color.
  • Fixed: objects created with RC2 are not upgraded to RC3 when using XRef scenes.
    * This problem occurs in the main scene, not in the XRef'd one.
    * Once saved with RC3, failed objects cannot be fixed even loading them with this patch. To help with that, we added a Maxscript function to fix them manually. Just select one by one, and run: $.upgradeFromVersion(275)

  • Fixed bug with Clipping Areas when using Generator->Z Offset.

  • Fixed: "easeOut" function was wrongly named as "easeOn".
    * Please note that if you was using "easeOn" in your expressions, these must be changed manually.

  • Description of easing functions (easeIn, easeOut, easeInOut) is rewritten to a more descriptive text.

  • Fixed crash with V-Ray IPR.

  • Fixed: RailClone Tools doesn't apply material and UVW transformations when "Separated Meshes" is enabled.

  • Fixed: User toolbars using RailClone actions are reset when Max is loaded.

  • Fixed bug with Bevel Corners in A2S generators using a vertical Y spline.

  RailClone Lite/Pro 3.0.9

RailClone 3.0.9

  • Added "Separate Meshes" option to RailClone tools.

    • When enabled, creates separated meshes for the non-instantiable segments, instead attaching all of them.

  • RailClone Tools generates correct meshes (no instances) for segments using Material or UVW operators.

  • Fixed crash in Library Browswer using libraries downloaded with old version of Update Manager.

  • Fixed: Clipping Area is not aligned correctly when using Generator->Z Offset.

  • Fixed crash with some operations after deleting a Note in Style Editor.

  • Fixed crash in RailClone Lite loading scenes created with Pro version.

  • Fixed rare crash with Clipping areas.

  • Fixed behaviour of arrays when using X Rotation and Surfaces (in this case segments are aligned, but not conformed to the Surface).

    • Fixed endless loop when using circular references between nodes..

  RailClone Lite/Pro 3.0.8

Changes between 3.0.7 and 3.0.8

  • Arithmetic->Expression fixes:

    • ">=" and "<=" operators in RC2 expresions are now correctly converted.

    • "print" command now displays the result if nodes's output is connected.

    • Pow operator (^) is evaluated from right to left.

    • Evaluate action shows a warning if the RailClone object could not be built correctly.
  • Fixed object corruption when importing duplicated materials from the library.

  • Fixed: RailClone Color from map now computes UVW coordinates using the center of the segment's bounding box.

  • Fixed geometry issues moving or transforming together a RC object and its clipping area.

  • Fixed extra "Random Rotation 2" entry in UVW XForm export parameters.

  • Fixed crash using Display->Update on interactive rendering (both Corona and V-Ray).

    • Note: Usually Update action doesn't only rebuild the RailClone object, but also clears some caches and data used by the plugin.

    • On interactive render, this step is omitted because may crash Max. Therefore, behaviour of Update action may be different in both cases.

  • Slots connected to exported Attributes are renamed using correct prefix.

  • Fixed: Randomize->Export Parameters is not updated when new nodes are connected.

  • Fixed: Randomize->Presence has no effect is parameter is exported.

  • Fixed: Generator->Z-Offset is not applied to Point-cloud.

  • Fixed: Style Editor->Close tab closes all tabs to right, instead only the current one.

  • Fixed creation context menu when connecting a numeric operator within a macro.

  • Fixed: Nested RC objects may look different from viewport and render.

  • Fixed: Macro On/Off has no effect.

  • Fixed: Macros connected to expandable operators (as Randomize) creates duplicated links when edited.

  RailClone Lite/Pro 3.0.7


New Features


  • Added Macros . This feature allows you to create new nodes by creating sub-graphs. Macros to output numeric values, geometry, and generators are all possible.

    • A new Macro library panel is available in the Style Editor containing system and user generated macros

    • Create or edit a macro by selecting a Macro node, right-clicking and selecting Macro > Edit

    • Input nodes allow you to determine the base objects used by a macro. These will become the macros inputs.

    • Output nodes allow you to determine the type of output generated by a macro. Choose from segment or numeric.

    • One or more Generators can be added to a macro.

    • Several examples are included, and you can save, share and import your own macros as well as adding them to a user library for easy reuse.

  • Added Update Manager , a new application to download and keep the software updated.

    • Libraries, Maps and Macros have been removed from the setup program. Now are downloaded from the Update Manager.

    • It requires to login with the username and password included with your license.

    • In the current version, the plugin is not updated from the application. This feature will be included in next updates.

    • Update Manager is launched periodically from 3DS Max, notifying the use of updates if there are any. You also can run it manually from General>Update or from the Start Menu.

    • Library, Materials and Maps are moved to C:\Users\<user>\AppData\Local\Itoo Software\RailClone

  • New algorithm to align Linear Generator with planar and closed splines. It computes initial banking angle (X Rotation in Generator) so segment's Z axis is perpendicular to the plane formed by the first and last spline's segment. This method works much better when creating frames, windows, etc.

  • Added Auto Align option to Array Generator->Extend X/Y Size mode. This option creates array aligned automatically with each sub-spline. This mode is very suitable for roof and panels.
    Two modes are available. For both modes Z axis is always perpendicular to the plane formed by the spline.

    • X --> XY : X axis is parallel to the RailClone XY plane (considering local axis of the object).

    • to Spline : X axis is aligned with first Spline's segment (you can use "Make first" vertex and "Reverse" spline to modify alignment).

  • Added Generator A2S->Clipping Area-> Hierarchy Checking Mode . This options determines the way that RailClone processes stacked splines for Extend X/Y Size mode.

    • Complete uses the original RC2 behaviour, stacked splines are alternatively include/exclude geometry

    • None treats each spline as unique, overlapping or stacking splines has no effect

    • ' By Material ID uses the material ID assigned to the splines to determine which belong to the same array.

  • Added RailClone Color : A new map type that is similar to Forest Color, providing random textures and tint to each segment.

    • Compatible with V-Ray, Mental Ray and non-instanced geometry.

    • Number of maps is increased to 20 (instead of 10 for ForestColor).

    • In future Forest updates, ForestColor and RailClone Color will be interchangeable.

    • Added "Color Seed" to Transform node. If not zero, value is used as random seed for RailClone color

  • Added Style Linking : This feature lets you to link a RC object to another, so Style changes done on Master are dynamically reproduced on slave.

    • Update is done when Style Editor is closed, importing a Library Style or manually clicking the 'Update' button.

    • Optionally material is also copied from Master object.

    • Parameter values are copied from master as well, except those have been modified by the user. This mechanism works in same way than Library/Copy Style operations, and the behavior can be modified from "General" settings.

  • Added 'Retain Value Mode' to Numeric parameters. It overrides behaviour for Retain value feature (used on Library, Copy Style and Style Linking procedures):

    • Auto : parameter value is retained if has been modified by the user.

    • Local : retain always value of local parameter.

    • Global : parameter is always overwritten, copying value from the master RC object.

  • New libraries: Roofing tiles , Hips and Ridges , and Cladding .

Improvements


  • Added support for V-Ray 3.6.

  • Added support for Max 2018.

    • Note: Mental Ray is not supported for this version.

  • New Max.time variable to returns the current time (in ticks).

    • Note: When Max.time is used in any expression, the RC object is updated at each frame. This may degrade performance.

  • List boxes in Parameters and Base Objects rollouts are resizeable .

  • Internal changes for compatibility with third-party renderers.

  • Note nodes have been rewritten. They are now resizeable, have user definable colours and can move child nodes.

  • Limit by ID can be used in Array generators when "Clipping->Extend X/Y Size to Area" is enabled.

    • In this way, the ID limit is applied to the clipping spline, not to the base X/Y splines.

    • The ID of first spline's section is used for checking.

  • Added mode to Compose: In Sequence or Grouped :

    • In Sequence uses the default behaviour, following Segments in order.

    • Grouped uses the first Segment as Main, which defines size and placement in the Generator sequence. Other segments are placed stacked in same position, according to their alignment settings. Note: some advanced operations as Bevel Corner, are not compatible with Stack mode and can generate incorrect results.

  • Instancing is disabled for certain Library styles, when current renderer doesn't support it.

  • Continuous mapping feature (Segment->Mapping) is completely rewritten. Now it should generate correct mapping under all conditions.

    • Due to the changes introduced, mapping may look different from RC2.

    • Segment mapping from non-converted RC1 objects doesn't work anymore. You must convert these objects to RC3 format.

    • Origin of UV coordinates (U=0,V=0) is aligned with the base spline.

  • Added UVW Offset to Generators.

  • Added Y Spline mode to A2S Generator: defines what coordinates are used for the Y Spline: Y/Z or X/Y.

    • X/Y was the mode for RC2 objects. RC3 objects uses Y/Z mode by default, which is more logical.

  • Style->Operate On is changed to Quad by default.

  • More Generator parameters are available for exporting (specifically combo values).

  • Transform->Fixed Size is computed before applying other transformations (as Rotate or Scale).

  • Updated expressions engine to V3. Changes:

    • return <expression> ;

    • * '=' changed to '=='

  • Added option to extract all Segments to the scene.

  • New dialog for Export Parameters/Attributes . It allows to change multiple parameters from multiple selected nodes (of same type).

  • Seed parameter now is animatable.

  • Added Pivot Offset to Transform node.

  • Added next properties to Arithmetic->Expression :

    • XSplineNextMatID : Material ID of next X Spline's segment. With Corners, returns ID of segment AFTER the corner.

    • YSplineNextMatID : Material ID of next Y Spline's segment.

    • SegmentXRole : Role of current segment in a Linear Generator. Can be used also within a row of an Array (0 = Undefined, 1 = Default, 2 = Start, 3 = Corner, 4 = Evenly, 5 = End)

    • SegmentYRole : Role of current segment in an Array Generator  (0 = Undefined, 1 = Default, 2 = Bottom, 3 = Corner (unused), 4 = Evenly, 5 = Top)

    • XVertexIndex : (index of X spline's vertex)

    • XEvenlyNumber : Number of Evenly positions on X path.

    • YEvenlyNumber : Number of Evenly positions on Y path.

  • Modified the way that arrays are generated when using multiple splines. Previously rows were created using all splines (Row 1 of Spline 1, Row 1 of Spline 2, etc). Now one array is generated completely for each spline (Row 1 of Spline1, Row 2 of Spline 1, etc) allowing their row sizes to operate independently.

Other changes and Fixes

  • 3DS Max 2010/2011 are not longer supported.

  • Changed: Generator A2S->Limits and Padding don’t work when using Clipping

  • Changed: Linear Generator->Evenly->Sync Offset is does not function when using Count mode and has been disabled.

  • Area->Extend X/Y Size. Settings have been disabled in this mode.

  • Fixed: Material operator generates different sequences when used on several generators.

  • Fixed: Randomize operator exports incorrect attribute values.

  • Fixed: Randomize, Sequence and Material operators are incremented twice when using exported attributes.

  • Fixed: Exported Counter parameter doesn't work with Sequence nodes.

  • Fixed rare clipping issue using planar segments (zero width along the axis projection).

  • Fixed: UVW XForm is not applied in V-Ray.

  • Fixed rare issue in V-Ray with meshes using specified vertex normals.

  • Fixed bug with Evenly segments on closed splines.

  • Fixed: Arithmetic->Expression->XSplineNextMatID doesn't work with Fillet Radius.

  • Fixed: when creating a new node, dragging a category title to the canvas causes a crash

  • Fixed: Closed splines planar to XY would generate flipped objects.

  • Fixed: Conditional->Angle returns wrong angle for first vertex of closed splines.

  • Fixed: Surface modifies Material IDs of conformed spline.

  • Fixed issue with disabled Sequence operators and Bevels.

  • Fixed: Expression's 'print' statement doesn't print result.

  • Fixed: "X Spline Start" event was triggered for each array row (now only with the first one).

  • Fixed "SegmentXCounter" value for Start/End/Corner/Evenly segments. This is a separate counter from Default segments.

  • Expressions of RC2 using Trigonometric functions are converted to use Radians instead Degrees.

  • Fixed: Segments disappear on closed spline if Y Offset >= Generator Padding.

  • Fixed: 'Display Limit exceeded' is not shown as error in General rollup and Lister.

  • Fixed Generator->Z Offset issue when using Segment->Deform->Adaptive mode.

  • Fixed alignment of Y Evenly rows when applying Bottom Padding to A2S Generator.

  • Fixed erratic movement of Max objects when Style Editor is closed selecting other object.

  • Fixed missing Segment using Evenly on closed splines.

  • Style evaluation has been improved to remove redundancies and fix related bugs.

  • Fixed: Style Editor cannot close if Listener is open.

  • Fixed: Style Linking is applied to wrong objects, messing parameters and causing unexpected issues.

  • Fixed: In a cloned object, all parameters are initialized as 'unused', for the 'Retain Value Mode' feature.

  • Fixed crash when deselecting the RC object with the Expressions editor open.

  • Fixed minor bug with Scale mode and Bevels on straight splines.

  • $.createdVersion is not copied anymore from source objects, on Copy Style and Library operations.

  • Fixed alignment on Vertical/Stepped modes when Generator->X Rotation is greater than zero.

  • Fixed crash when connecting Arithmetic node using an empty expression.

  • Style Editor->Undo operations doesn't modify scene state (as position and zoom).

  • Fixed crash with dynamic geometry render and segments using TurboOptimizer modifier.

Changes between 3.0.6 and 3.0.7

  • Fixed: Update Manager returns "Unknown Error" for common issues as a wrong password.
  • Fixed Arithmetic->Expression issues:
    • 1*-1 is not evaluated correctly.
      ( * ^ operator has lower precedence as intended.)
  RailClone Lite/Pro 2.7.5
This release adds compatibility with V-Ray 3.6
  RailClone Lite/Pro 2.7.4
Includes several fixes and improves the ability to update multiple RailClone objects when using the Library or Copy Style operations.
  • Fixed crash on Library Browser when importing without an item selected.
  • Fixed potential issue of Clipping areas with multithreading.
  • Fixed crash on Conditional operator when using "Multiple of" with a Parameter returning zero.
  • Fixed crash on Max close.
  • Added support for long paths in registry configuration values.
  • Improved behaviour of retain parameters feature with Library and Copy Style operations.
  • Fixed random crash in V-Ray when using dynamic geometry and certain types of segments.
  RailClone Lite/Pro 2.7.0

Adds support for Max 2017 and V-Ray 3.4 and includes bug fixes as detailed below:

  • Added support for Max 2017.
  • Added option to customize Font Size for the Lister (see Options).
  • Actions of the Toolbar are available at "Customize User Interface" (within "RailClone" category).
  • Modified Library behaviour: when a style is loaded, all objects in the scene using that syle are updated. (see Note 1)
  • "Copy Style" and Library updates retain value of parameters which has been modified by the user. (see Note 1)
  • RailClone Lister is sorted by object's name.
  • Fixed: No Geometry error if an empty segment (with size) is used as initial segment on a Sequencer or Conditional operator.
  • Fixed error with Points-cloud mode if RC object has not a material assigned.
  • Fixed invisible objects in V-ray when using VRayPhysicalCamera with motion blur or PhysicalCamera.
  • Fixed: Library load doesn't update current if style is used on scene in more than one object.
  • Fixed: Toolbar placed out of screen and not visible. (see Note 2)
  • Fixed: Toolbar is not available after a Workspace change.
  • Fixed bug with Bevel and corner angles that are exactly 180 degrees.
  • Fixed incompleted segments with Bevel and Extend mode.
  • Fixed crash of Style Editor in Max 2011- 2012 64 bit.
  • Fixed colors in Points-cloud mode.
  • Fixed potential issue with Edit->Clone procedure.
  • Style->Thumbnail is updated on "Copy Style" operations.
  • Fixed: Style->Thumbnail and Description were not visible if Libraru Browser was not initialized.
  • All configuration keys defined at HKEY_LOCAL_MACHINE can be read alternatively from same branch at HKEY_CURRENT_USER.
    This feature lets you to create custom installations using non-administrative accounts.

 

Note 1

This behaviour can be overrided from General->Options.

Note 2

If toolbar is not visible even after this update, try removing the following file and restarting Max:

C:\Users\<your user name>\AppData\Local\Autodesk\3dsmax\<your max version>\ENU\en-US\plugcfg\railclone_toolbar.ini

  RailClone Lite/Pro 2.6.0

 RailClone 2.6 requires a license upgrade. See this post on our knowledge base for details.

  • New Features and Fixes

  • Added support for V-Ray 3.3.
      • RailClone 2.6 benefits of the render performance improvements of V-Ray 3.2 and greater. In our tests speed gains were between 40% to 100% depending of the scene.

      • V-Ray 1.5, 3.0, 3.1, and 3.2 are not longer supported. Currently supported V-Ray versions are 2.5 and 3.3.
  • Added a toolbar with shortcuts to: add RailClone object, Open RailClone Tools and RailClone Lister.

  • Added a new RailClone Lister

      • This new tool simplifies the management of scenes that contain multiple RailClone Pack objects.
      • It comprises a simplified interface allowing you to rename, enable/disable, hide/unhide, and select Forest objects, display useful information, and speed up editing properties.
      • For more details see the documentation .
  • Added support for V-Ray motion blur and velocity channel with animated proxies and meshes.
  • Improved hit-test viewport performance for mesh modes.
  • Fixed random crash rendering animations in V-Ray 3.
  • Fixed bug with VRayProxies and Bevels.
  • Fixed potential corruption issue when save is not completed correctly.
  • Fixed: Spinner dragging on Style Editor generates multiple undos.
  • Fixed: Redo operation on Style Editor changes selected node.
  • Fixed endless loop when using arrays with paddings greater than spline's length.
  • Fixed behaviour of Sequence Operator on Bevels.  (see note 1)
  • Fixed bug with random numbers and nested objects. (see note 1)
  • Fixed bug in Arithmetic operator when input values are not of the same type.
  • Fixed: Bevel is not applied correctly on vertices with very small change of angle.
  • Fixed: Extended/Symmetry Bevels don't work if segment is larger than length of initial section path.
  • Fixed bug which on rare cases could generate sliced instances when using arrays.
  • Fixed bug with initialization of parameters in Arithmetic expressions.

Note 1:  To keep compatibility with previous scenes, this fix is applied only on new RC objects.
If you want to "upgrade" your RC object so it works as created with the recent release, select it and run this on Maxscript: $.railclone.resetCreatedVersion()

  RailClone Lite/Pro 2.4.6
  • New Features and Changes:

  • Added Style Description. Lets you to see at a glance a general description of the style, base objects and parameters.
    • Use Style Editor->Style->Edit Description to edit, and Style rollout->Help button to show description.
    • Added Maxscript functions to get/set Style Description: $.railclone.getStyleDesc(), $.railclone.setStyleDesc("my style")
  • Added UVW XForm operator to edit and randomise the tiling, offset and rotation of existing UVW map coordinates (*)
    • UVW XForm->Random->Step Increment. Enables random values to increment in steps (for example rotation could be randomised between 0° and 360° in 90° steps).
  • Added Export Attributes. This feature enables the exporting of numeric values from nodes, for example the size of a Segment. To use it: select Segment->Right Click->Export Attributes.
  • Segment->Mapping accepts multiple map channels. Write them separated by spaces (*)
  • Added Generator->Limits->Padding (Start/End for Linear, Left/Right/Top/Bottom for Arrays).
  • Added two modes for Generator->Rules->Evenly: Distance and Count. Distance works as before, and Count creates a fixed number of elements.
  • Exportable Parameters and Attributes are sorted by category.
  • Added more exportable parameters to Segment and Transform nodes.
  • Added Clear all to Export Parameters and Attributes.
  • Improved conform to Surface for very large splines. Added parameter to define interpolation's step: Style->Geometry->Surface Interpolation (5cm by default).
  • Conditional->Vertex can be used with Default slot. It checks the latest vertex before the Default segment.
  • Display->Use Geometry Shader is renamed to Use Instancing Engine.
  • RailClone Tools->Instantiate copies User Properties, Object ID and wireframe color of the source object (when present).
  • Added Segments Selector to Quad menu.
  • Added warning message to General->Stats to inform of features not compatible with instancing.
  • Installer supports multiple Max versions.
  • Improved handling of multi threading. Also fixed rare crash on certain conditions.

(*) Segments using these features can be instanced only in V-Ray, though these operators can be used with all render engines and RailClone Tools when Display->Use Instancing Engine is off.

 

 

  • Style Editor:

  • Multiple wiring support, selecting several nodes of the same type and dragging (e.g. to connect multiple Segments to a Randomize operator).
  • Added Segment->Right Menu->Clone Multiple. Clones a Segment multiple times, using objects from the scene as source.
  • Improved detection of hotspot for node wiring.
  • Style Editor can be placed at left side on multi-monitor configurations.
  • Randomize->Presence and Sequence->Counter parameters are available for exporting
  • Auto rename of Parameters and Base Objects on wiring.
  • Added result of Arithmetic->Expression on edit dialog.
  • Wires can be dragged directly over a node, connecting them to a default slot depending of the wire's type.
  • Dragging between nodes outputs swaps their links.
  • All nodes include an On/Off exportable parameter. This parameter is independent of the clickable On/Off state.
  • All boolean parameter are available for exporting.
  • Clipboard file (rcclip.dat) is stored in a temporary folder.
  • Fixed: nodes with multiple inputs were keeping empty slots after links deletion.
  • Fix: added creation context menu for wires dragged from Clipping Area slots.
  • Library:

  • The following styles has been completely redone, using the new RailClone features and improved materials
    • Architecture->Exterior->Fences->Metal
    • Architecture->Exterior->Fences->Vinyl
    • Architecture->Interior->Railings
    • Civil Engineering->Pavements->Curbs
    • Civil Engineering->Pavements->Sidewalk

Fixes:

  • Fixed: Value of Random node was generated before evaluating its exported parameters.
  • Fixed bug of Evenly Segments when using Surface.
  • Materials are not longer XRef'd when Override Material is off in the Library item properties.
  • Fixed: Stepped segments are not instanced correctly on curved paths.
  • Fixed padding of initial segment on closed paths when Bevel is off.
  • Fixed behaviour of Generator->Adaptive/Scale/Count mode when using Transform operators.
  • Fixed trimming of Generator->Limits->Padding on offset paths.
  • Fixed updating of clipping areas when using nested RC objects.
  • Fixed size now works properly with Generator->Scale/Adaptive/Count modes.
  • Fixed behaviour of Fixed Size when Segment->Transform->Transform Affect Size is off.
  • Fixed: Generator->Limit by ID uses a wrong range ([0..n-1] instead [1..n]) when parameter is exported.
  • Fixed: in some cases the last segment of a linear generator would be skipped when using negative paddings.
  • Fixed rendering of RC objects with modifiers in Corona Renderer.
  • Fixed: Segment->Deform->Nest was applied always in V-Ray, regardless of the parameter value.
  • Removed wrong warning when connecting Arithmetic node to Segment->Exported Attributes.
  • Nodes with exported attributes are properly collapsed.
  • Fixed behaviour of Segment->Flat Top/Bottom when pivot is not aligned to bottom.
  • Fixed bug of Compose node when using Segment->Alignment different from Automatic.
  • Removed isolated vertices on Generator->Clipping process.
  • Fixed behaviour of Generator->Align to Path with Corner segments and closed splines.
  • Position of panels in Style Editor is saved and restored properly.
  • Fixed crash modifying objects assigned to a segment (Max 2010 and older).
  • Removed limits from Generator->Fillet Radius.
  • Vertex Color channel is generated only when needed.
  • A2S Generator->Clipping->Rotation Z now works in local coordinates.
  • Segments are updated when their referenced objects are converted to editable mesh.
  • Generator->Clipping deletes isolated vertices.
  • Fixed rare bug when using no Bend segments at Corners.
  • Fixed rare bug with empty segments (see  here  for details).
  • Fixed potential crashing bug moving cursor on viewports while render (V-Ray and Max 2015 only).
  • Improved behaviour of Fixed Size with empty Segments.
  • Segment->Mapping is aligned correctly when applying random scale.
  • Clipping Area is properly updated when Generator is off.
  • Fixed bug that would disable Start/End segments when using Base Object->Start/End limits.
  • Fixed Style Editor disappearing problems on multi-monitor configurations
  RailClone Lite/Pro 2.3.4
  • Fixed: Y counter is not computed correctly when using clipping areas.
  • Fixed random crash with points-cloud mode in Max 2015.
  RailClone Lite/Pro 2.3.3

New features and changes:

  • Added support for Max 2015.
  • Conform to Surfaces.
    • Enables segments to conform to the geometry of a surface, following the Z axis of the RailClone object.
    • New type of object: Surface. Used to assign the surface object.
    • Added Surface slot to Linear and Array generators.
    • New Segment Parameter: "Deform>Align Y with Surface". Applicable only to L1S Generator, align the segment's Y axis with the surface's normal.
  • Added Fixed Size for Segment and Transform nodes. If greater than zero, fixes the size of a segment.
    • Added scale mode to the Fixed Size feature in Segment and Transform nodes.
    • Added checkbox to enable "Fixed Size" in Transform operator.
  • Added Corner>Bevel Corner for Linear and A2S Generators. 
    • Added Generator>Rules>Corner>BC Offset. Lets you to adjust the position of the Bevel Corner.
  • Added Corner segment for Array Generators (Inner Corner slot).
    • Added Corner>"Fillet Radius" and "Align to Path" properties to A2S Generator.
  • Random node can use its own seed. If disabled, uses the global seed value.
  • Improved instancing efficiency when using stepped segments.
  • Added support of Vertex Alpha, and Vertex Illumination channels.
  • "Display>Adaptative>Degrade to" changed to "Boxes" as default mode.
  • Improved VRay render performance on many core machines.
  • Added Evenly>Reverse for all generators.
  • Display>Adaptative mode may degrade to Boxes or Pointscloud (default value). This selector is global for all RC objects.
  • Improved behaviour of A2S Generator>Evenly segments on Free mode.

Fixes:

  • Fixed stability issues with Thea Render/Corona Render/VRay RT.

  • Fixed geometry issues with clipping area when scene units is meters.

  • Fixed rare "Display limit exceeded" error with scale mode.

  • Fixed geometry errors using bevels and negative Y segment offsets.

  • Fixed crash on Conditional operator using "Material ID>Multiple of".

  • Fixed geometry differences between viewport and render when using high values of Segment>Transform.

  • Fixed crash turning on Generator>Reverse without a spline assigned.

  • Fixed bug that would change random values when editing a style.

  • Fixed: Display>Render settings were ignored with certain render engines.

  • Fixed error loading scenes which has been saved in computers without RailClone installed.

  • Fixed geometry error on A2S Generator using Spline Y and X Rotation.

  • Evenly rule doesn't modify type of line (Curve/Line) in the spline.

  • Arithmetic>Expression>XVertexAngle and XVertexAngle functions were switched.

  • Fixed geometry errors using bevels on closed splines.

  • Materials are properly displayed in the viewport when assigning library styles.

  • Fixed: Style Editor may disappear on certain multimonitor configurations.

  • A2S Generator>Clipping Area>Projection is forced to Z when using "Extend X/Y Size to Area".

  • Fixed rendering issue with VRay RT.

  • Fixed: closing Style Editor on dual monitors configurations would generate a rightclick event.

  • "Fixed Size" feature works properly with all alignment modes.

  • Fixed error of Conditional operator using "Multiple Of" and certain values (2.3.0b error).

  • Fixed: "Fillet Radius" modifies material ID on closed splines.
  • Fixed: Display->Build->Auto is ignored when modifying segments.

  • Fixed rare bug of "Flatten Stepped" with mirrored End segments

  RailClone Lite/Pro 2.2.3

Library:

  • Over 75 new styles:
    • Architecture->Exterior->Fences->Wood
    • Architecture->Exterior->Guttering
    • Architecture->Interior->Circulation->Escalators
    • Architecture->Interior->Flooring
    • Entourage and Props->Shelving and Storage
    • Entourage and Props->Crowd Control
  • Library scheme has been reorganized to include the new and future styles.

New features and changes:

  • Array generator is available in RailClone Lite.
  • Added support for V-Ray 3.0 and Thea Render.
  • New Parameter node: Random number.
  • Added General->Stats information window.
  • Added Segment->UV Mapping->Rotation.
  • New Default mode: Count, allows to define a fixed number of segments.
  • Linear 1S Generator can be built without a spline, setting X Size parameter.
  • Added Style->Geometry->Free Object.
  • When enabled, RailClone doesn't use the spline's position, only its shape. Use it to move RC freely along the scene (without the spline), or to create instanced objects.
  • Added up/down arrows to Base Objects/Parameters lists.

Style Editor:

  • Added icons and shortcuts for Enable (Ctrl+E), Disable (Ctrl+D), Expand (Ctrl+X) and Collapse (Ctrl+L) actions.
  • Renamed exported parameters of Transform operator to match with Segment ones.

Fixes:

  • Fixed error that would generate misaligned segments on render.
  • Fixed error using geometric shader and mirrored segments.
  • Constant parameters are affected by Geometry->Global scale.
  • Fixed: Compose operator works properly with Default->Scale mode.
  • Fixed: Material Sequence operator was adding +1 to the ID value.
  • Fixed: Segment->Flat Top/Bottom controls are disabled if Bend is off.
  • Fixed alignment of initial segment when using Vertical or Stepped mode.
  • Fixed: some arithmetic expressions are evaluated as integer values.
  • Fixed Randomize operator with nested RC objects.
  • Fixed Region Clipping using nested splines on specific viewport aligments.
  • Fixed several bugs with Segment->Mapping.
  • Fixed alignment issues with certain Y Splines on arrays.
  • Fixed potential crash on Max exit.
  • Fixed crash when Style Editor close if there are nodes selected.
  • Fixed crash cloning Mirror nodes.
  • Fixed: length of Left Padding on empty segments is double as intended.
  • Note: to keep compatibility with existing scenes, this fix is applied only in styles created with v.2.2 or above.
  • Fixed error in Scale mode when using Bevels and Fillet Radius.
  • Fixed alignment error when using Scale mode and Bevels.
  RailClone Lite/Pro 2.1.6
  • Fixed potential lockup on scene save.
  RailClone Lite/Pro 2.1.5
  • Added support for VRay 3.05.03 beta.
  • Fixed crash on Style Editor when using Parameter->Constant operators.
  • Animated segments are properly updated with Display->Geometry shader is off.
  • Animated Parameters and Base Objects are visible in the Track View.
  • Fixed: Transform Operator was applying global scale twice.
  • New algorithm for no-Bend Segments was not working as intended. Reverted to 2.0.4 version.
  RailClone Lite/Pro 2.1.3

Style Editor:

  • Style Editor is now integrated within Max. Stay-on-top is not longer needed, all connection issues should be solved.
  • Added Selector operator: selects a Segment according to an index.
  • Added Transform operator: transform and modify properties a segment (alignment, padding, scale, etc.)
  • Added expressions to Arithmetic operator.
  • Added contextual creation menu (using right click->Add or dragging links).
  • New subtype of Numeric parameter: Boolean (returns 0-1).
  • Most of nodes can be turned off (clicking checkbox at right top corner when is selected, or by right click contextual menu). Each node has a specific behaviour when is off.
  • Generator->On field is not longer needed and has been removed.
  • Alt+Click selects a node and its childrens.
  • Added Ctrl+C / Ctrl+V shortcuts for Copy / Paste actions.
  • Allowed zoom over 100%. Set zoom limit at Options->Preferences.
  • Added Options->Preferences->Rename Segments when Reload (on/off).
  • Added Options->Preferences->Show Warning Messages (on/off).
  • Exported parameters are highlighted in red color.
  • Improved undo/redo.
  • Fixed limits of several parameters.
  • Fixed: Segments can be connected to exported parameters.
  • Delete key doesn't remove items anymore, when used from Style Editor controls.
  • Spline node is updated in the Style Editor when assigned from Base Objects and viceversa.
  • Spline can be cleared from Style Editor using context menu->Clear.
  • Fixed potential crashing issue picking objects from Style Editor.
  • Fixed limits of exported parameters.
  • Material Operator->From/To parameters can be exported.

New features and changes:

  • Added support for VRay 3.0 beta.
  • New parameter: Style->Geometry->Simple Y Offset mode.
  • RailClone uses a sophisticated algorithm to compute Y Offset paths, but it some cases it would not generate a correct result.
  • We have included an alternative simpler mode that could solve these cases. Enable it if you get distorted geometry when using Y Offset.
  • Added Adaptive mode for Generator->Rules->Default. Bevels are not allowed on this mode.
  • Added Adaptive mode for Generator->Rules->Evenly.
  • Added Vertical Top/Bottom for Segment->Stepped mode. It works similar to Flat Top/Bottom for Vertical mode.
  • Added A2S Generator->Clipping area->Extend X/Y Size to Area->Expand.
  • Improved precision for alignment of segments with Bend off.
  • RailClone Tools sets Octane "Movable Proxy" property to the instanced items.
  • Display->Render->"VRay/Mental Ray shader" renamed to "Use Geometry Shader".

Fixes:

  • Animated Segments are properly updated.
  • Fixed Conditional->Y Counter when usign Y Evenly.
  • Fixed several geometry issues with Generator->Limit by ID.
  • Array Generator using Free mode works correctly with negative Y Size values.
  • Randomize Operator works properly with Start/End/Left Side/Right Side.
  • Randomize->Percentage is limited to 0-100.
  • Fixed Y Offset issues with closed splines.
  • Generator->Default->Scale handles correctly Composed segments.
  • Fixed Y Sequence operator when used with Evenly/Corner.
  • Fixed bug with no-slice segments and paddings.
  • Fixed right menu on Library Browser when there are not items selected.

Library:

  • Several presets has been fixed or improved (handrails, ducting).
  RailClone Lite/Pro 2.0.4

Style Editor:

  • Copy/Paste now works between RailClone objects.
  • Fixed potential lockup saving large scenes when editor is open.
  • Fixed: Right click on spinners resets to wrong values.

Other:

  • Fixed: Segment->Rotation to more than one axis generates squeezed objects.
  • Fixed: Parameters limits are not properly updated in the Max rollout.
  • Library: Fixed alignement of Civil Engineering->Curb elements.
  RailClone Lite/Pro 2.0.3

In this update, the plugin has been rewritten from scratch, introducing significate improvements over RailClone 1.x. These are only a few of them:

  • Graphical Style Editor.
  • Multiple Generators by object.
  • Array generators, based on two splines or dimensions.
  • Multiple Base Objects (splines) by object.
  • Node Operators: Sequence, Randomize, Mirror, Arithmetic and others.
  • Selectable segments according to spline properties, using Conditional operator.
  • Segments by spline's material ID, using Generator->Limits or Conditional operator.
  • Random material mode is much more flexible, using the Material operator.
  • Area Clipping (include and exclude), using closed splines.
  • New display mode: Points-cloud.
  • Exported Parameters, lets you to parametrize models much more easily.
  • Added Stadium seats to the Library (Bleachers category).
  • Library items are improved for 2.x new features.
  • Added support for Max 2014.

...and much more. See the  demo reel , help reference and the new  tutorials  for more information.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Save

Save

Save

Save

Save