Is it possible to have RailClone 1.x and 2.x installed at the same time ?

Not with the same Max version, but it can be done using separate Max installations. For example, lets say you want to install 1.x in Max 2010 and 2.x in Max 2013:

Step-by-step guide

  1. Install RailClone 2 in Max 2013, using the default installation options.
  2. Run the installer of 1.x, select Max 2010 and modify the destination folder, i.e. to C:\Program....\RailClonePro1\
  3. In Max 2010 (RC 1.x), replace the file <maxdir>\scripts\startup\railclone_utils.ms with this file: railclone_utils.ms (to avoid the "RC_getRenderer" error).

On the other hand, this procedure is not necessary if you only want to render scenes of RailClone 1.x in 2.x, but not edit the objects: just do not convert the object to the new format in the Modify panel. By default RailClone 2 uses the old engine to build and render the 1.x objects, so the result should be identical.