Effects Library

Overview

The Effects Browser allows you to easily navigate the effects that ship with Forest Pack. It also allows you to import and manage your own effects or effects obtained from a third party. Using the effects browser makes it fast and simple to quickly add additional functionality to Forest Pack exactly when you need it.

Effects are saved in .eff files. These can be created using the Export feature of the Effects Editor, see this feature's reference for more information.

In this section:

 

 

Procedures

To open the Effects Browser

  1. Go to the Effects rollout.
  2. Click on the button to add a new empty effect. 
  3. Click to  open the Effects Browser.

To load an Effect using the Browser

  1. Open the Effects Browser.
  2. Use the Effects navigator to select the Effect you wish to use
  3. Read about the effect in the description pane to see see instructions for its use. For extra information you may be able to click on the Click For Additional Help button to open our online documentation.
  4. Click .
  5. Adjust the properties if necessary from the Effects rollout.

To access and load user and 3rd part effects from the Effects Browser

  1. Choose User Path from the drop down list found above the Effects Navigator.
  2. Select an effect from the effect navigator.
  3. Click .

To create a Category in user Effects Library

  1. Right click in the Effects Navigator
  2. Click
  3. An add category dialog will open, enter a name and click OK.

To add a new Effect to the User library

  1. Right Click on a Category and select Import Effect.
  2. Select an .eff file and click Open.
  3. The .eff file will be imported and saved to your Effects Directory.

To delete an Effect from the library

  1. Select the effect you wish to delete from the Effects Navigator.
  2. Right click and select Delete Effect.

To open the Effect's save location in Windows Explorer.

  • Right click on an effect and click Open in shell.

To add information about an effect

  1. Select an effect from the Effects Navigator.
  2. Right click and select Edit Data.
  3. The Edit Data window will open.
  4. Enter a name for the effect in the title field (a). If this field is left blank the file name will be used.
  5. Enter a description (b). This contain any instructions and additional information a user requires in order to use your effect. (optional)
  6. Click Load to add a thumbnail (c). The plugin supports files of the type png, jpg, and .xpm. This image is displayed underneath the description in the effects browser. (optional)
  7. Additional help is used to provide a link to a website (d).  This could be more informtation about the effect, the author or anything else you feel is helpful. (optional)
  8. Click OK.

 

Though the Effect Browser allows you to import, delete and categorise your effects the plugin is actually just reading the directory structure of the user's effects folder. This means that it's easy to create new categories and organise effects using any file manager. By default user paths are saved in

C:\Users\username\Documents\Forest Pack\effects

Interface

  1. Library Menu. A drop down list to Select the library. By default you have two libraries, the Default library for built in effects and a User's library for your own effects.
  2. Refresh. Click to refresh the effects navigator. This is usefully if you've made changes to the library manually in a file manager and you'd like to see these updates in the Effects Browser.
  3. Effects Navigator. Displays a tree view of your selected library
  4. Category. A category is a way of organising your effects. Categories can be nested.
  5. Effect. An individual .eff file. Click to see more information about the effect.
  6. Description. Shows a text description and instructions of the selected effect.
  7. Preview Image. A image to illustrate the selected effect
  8. Click for additional help. Click this button to go to online help for more information about the selected effect. For iToo effects this takes you to our documentation server.
  9. Load. Click this button to load the selected effect.
  10. Cancel. Click this button to close the Effects Browser without making any changes.

When editing the user library you can right click in the Effects Navigator to perform different functions. Depending on whether you click on a Category or an Effect you'll get the following menus:

Category menu

  • Add category. Creates a new category in the selected location.
  • Delete category. Deletes the current category and its contents.
  • Import Effect. Import an .eff file into the current category.
  • Open in shell. Opens the directory of the selected category using your default File Explorer.

Effects menu

  • Edit Data. Opens the Additional Data menu used to include a title, description, preview image, and URL.
  • Delete Effect. Deletes the selected effect.
  • Open in shell. Opens the directory of the selected effect using your default File Explorer.

Additional Data menu

  1. Thumbnail. Displays a preview of the selected effect. The browser does not rescale images so it's recommended to save them in a size that's appropriate.
  2. Title. The name of the effect to be displayed in the Effects Navigator. If you leave this field blank the file name will be used.
  3. Description. Add additional information about the effect such as a description and instructions for use.
  4. Load. Click to select a preview image file in the format png, jpg, or xpm. The image is encoded in the .eff file so there's no need to include it if you share your files.
  5. Clear. Click to remove the current preview image.
  6. Additional Help (URL). Used to add a URL that can provide additional online help or information about the author.
  7. OK. Click OK to save changes to the effect and return to the browser.
  8. Cancel.Click Cancel to return to the browser without saving any changes.